Funktioniert xt:Commerce mit php7?

xt:Commerce 3 und xt:Commerce 4.2.00, sowie die vorangegangenen Versionen der Software sind derzeit nicht kompatibel mit php7. Einer der Hauptgründe ist, dass derzeit noch keine Version des Ioncube-Loader vorliegt die mit php7 kompatibel ist. Falls Ioncube hier zeitnah eine Lösung bietet, kann es durchaus sein, dass xt:Commerce zeitnah reagiert. Ioncube wollte zwar bereits Ende 2015 eine Lösung bieten, jedoch scheint es hier größere Probleme mit der Kompatibilität zu geben als bei anderen Anbietern.

xt:Commerce und php7

xt:Commerce und php 7

Ob der Support von php7 für xt:Commerce 4.2 nachgereicht wird bleibt abzuwarten, die Anpassungen die in der Software nötig wären sind (auf den ersten Blick) nicht extrem aufwändig. Laut xt:Commerce wird die folge Version voraussichtlich php 7 unterstützen, jedoch muss natürlich Ioncube hier zunächst eine Lösung schaffen damit xt:Commerce dieses definitiv bestätigen kann.

Bei xt:Commerce 3 kann man nur wie zu jedem php-Update empfehlen endlich auf xt:Commerce 4 zu migrieren.

 

Die Info hat Ihnen geholfen? Dann helfen Sie uns:

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *